Khắc phục Ubuntu thường xuyên bị treo?

Mọi người cho em hỏi , em đang dùng Linux Ubuntu nhưng nó hay treo quá ! Có cách nào khắc phục không ạ?
Hay là nên sài bản Mint đỡ lag ạ. Mong anh em chỉ giáo

1 Like

Bạn cài htop bằng lệnh sau:

sudo apt-get install htop

Lúc bị treo, bạn bấm tổ hợp phím Ctrl + Alt + (F1 => F6) để vào tty mode, gõ htop rồi enter để xem app nào đang ngốn RAM, kill app đó đi rồi bấm Ctrl + Alt + F7 để quay lại giao diện GUI.

1 Like

Nó đứng đơ luôn không nhấn phím nào được phải làm sao b ?
Toàn phải reset máy!
Máy trc giờ chạy win 10 rất ổn đinh chưa bị bao giờ kiểu treo này mà giờ qa Ubuntu chán quá !

1 Like

xài Linux mình thấy hay lỗi lắm bạn ơi, có thể thử qua thằng Fedora đó, cũng thấy ổn định nhưng nó hỗ trợ ít quá. Còn nếu yêu họ Debian thì dùng Mint cũng được nhưng mình không thích giao diện của nó cho lắm :slight_smile:

1 Like

Nếu bạn chỉ học tập đơn thuần thì Windows 10 giờ hỗ trợ cài Bash ngay trên hệ điều hành rồi nếu bạn thích có thể lên mạng tìm cách kích hoạt nó nên. Mình hiện cũng dùng theo cách này để học tập, bí quá thì chạy máy ảo chứ Linux mình thấy không ổn định lắm. Windows 10 giờ nó hỗ trợ tốt lắm bạn à :slight_smile:

1 Like

Bạn cứ nhấn xem được không đã: Ctrl + Alt + F1.
Nếu vào được thì cứ làm như mình bảo.
Còn ko vào được thì tắt đi bật lại, bật System Monitor để quan sát xem app nào làm ngốn RAM.

Máy mình trước dùng Windows rất hay bị đứng, như Chrome đang lướt thì No responding. Giờ qua Ubuntu rất hiếm gặp mấy trường hợp đó. Nếu gặp thì cứ vào tty mode để kill mấy process ngốn RAM.
Còn trường hợp đơ đến mức ko vào được tty mode thì bạn tham khảo một vài link sau:



Còn không bạn qua dùng thử Linux Mint cũng được. Nó nhẹ và nhanh hơn Ubuntu, nhưng không đẹp bằng Ubuntu và hỗ trợ cũng không nhiều bằng Ubuntu.

1 Like

Không rõ chủ topic sử dụng phiên bản Ubuntu nào? Dung lượng máy tính là bao nhiêu GB RAM?

Kinh nghiệm đau thương: RAM 4GB chạy Ubuntu 16.04 chỉ cài đặt lên không thôi không cài thêm phần mềm nào khác từ PPA hay download về thêm thì ổn, nhưng nếu cài thêm là chạy lag kinh khủng, swap như điên, lại phải chỉnh chọc thông số swappiness bằng tay - vãi linh hồn luôn.

Lời khuyên: dùng Ubuntu 14.04 tuy cũ nhưng ổn hơn.

2 Likes

Ram của mình 8G có swap thêm 8G đang sài bản 16.04 đó bạn :3 Kiêu này chắc xuống bản 14 thử

Cảm ơn Người bí ẩn nhiểu :slight_smile:
Để mình thử khi bị vậy :slight_smile:

Kì nhỉ, nếu RAM 8GB thì dùng 16.04 vô tư chứ!
Mình cũng 8GB RAM, ko để swap, code và chơi game bình thường, dùng máy ảo vào Windows 10 với Mint vô tư đâu bao giờ bị đứng đâu nhỉ!

1 Like

Mới ktra chưa cài driver NVIDIA không biết có liên quan j dến lỗi treo máy không nữa :v để xem sao :3

Cũng có thể là vì cái máy bạn nó vậy.
Phần cứng hỗ trợ Linux nhiều, nhưng xài êm thì không nhiều, trước khi mua máy (hoặc xóa win), bạn nên tham khảo trước https://certification.ubuntu.com/certification/ , nếu được máy nêu trong này thì lí tưởng, hiệu suất phải muốn tốt hơn Win
Lí tưởng không nổi thì bạn tham khảo list hàng của các shop bán máy cài sẵn linux trên mạng (vd: https://www.linuxnow.com.au/nsintro.html#excellentlinux), nếu người ta có thể cài vào và bán thì chắc chắn nó hỗ trợ. Dạng này thường phải cài thêm, chỉnh chỉnh gì đó, nếu rối thì email hỏi mấy shop kia luôn, có khi nó trả lời đó, shop nhỏ thường hiếu khách lắm.
Còn nếu bạn dạo đến 100 shop mà vẫn không thấy máy mình trong đó thì … :sunglasses:

Hi Thiên Tài.
Thường thì bạn cần xác định rõ nguyên nhân tại sao bị đơ do ram chíp đĩa cũng v.v.v… thì mọi người mới tư vấn được cho bạn chứ.
Khi nó bị đơ bạn Ctrl+ALT+F1 để vào gia diện dòng lệnh thuần. Sau đó đăng nhâp rồi gõ lệnh top để nó hiển thi các tiến trình đàng chạy và kiểm tra các vấn đề như CPU ram disk. Các bản ubuntu cũ hay gặp lỗi giao diện unity bạn thử chuyển qua dùng gnome hoặc openbox xem.
Một lý do nữa có thể do swap. Thường thì mặc định tỉ lệ swap là 60% tức là khi bạn dùng trên 4G nó đẩy một phần ram xuống swap. Với ram 8G và không có yêu cầu cao về ram như CSDL máy ảo v.v.v… thì tốt nhất là tắt swap.

1 Like

Theo qua điểm của mình về swap trên linux:
1 Với các máy ram thấp như VPS ram 1G thì nên để swap và tỉ lệp swappiness thấp vì thường chạy các tác vụ yêu cầu nhiều ram và biến động ram lớn. (Có thời điểm nhiều yêu cầu có thời điểm ít yêu cầu).
2 Với máy dùng hằng ngày 2G - 4G ram thì để swap 1G - .5G và để swappiness cao tận dụng ram và các tác vụ nhỏ không cần nhiều ram ngay lập tức mà tăng từ từ. (Nếu chạy máy ảo thì nên nâng ram)
3 Với máy ram > 4G và không có yêu cầu tác vụ gì cần nhiều ram như máy ảo CSDL lớn v.v.v… thì nên tắt swap vì khi bạn dùng hết 6G 8G ram tức là lúc bạn nên tắt bớt các chương trình không cần thiết hoặc xem lại cách dùng máy quản lý tải nguyên của mình.

Swap là một vung lưu trữ trên bộ nhớ ngoài. Khi lượng ram sử dụng vượt quá swappiness thì hệ điều hành tự động đẩy phần ram ít dùng (Các tác vụ khi khởi động, các chương trình nền, các cửa số không làm việc, các tab không dùng của trình duyệt v.v.v…) ra bộ nhớ ngoài. Nó giúp tăng thêm bộ nhớ cũng như đáp ứng các nhu cầu cục bộ như truy suất SQL hay link mã nguồn v.v.v… Nhưng vì bộ nhớ ngoài tốc độ đọc ghi chậm nên gây nên tình trạng lag v.v.v… Và việc đọc gi trên ram là ngãu nhiên nên khi đẩy lên bộ nhớ ngoài tuần tự thường làm giảm tuổi thọ phần cứng đặc biệt SSD,

2 Likes

cảm ơn b nhieu :slight_smile: Minh sẽ lưu ý nhung ý kiến của mọi ng :slight_smile:

Nếu triệu chứng của bạn là máy đơ hoàn toàn, không ấn được bất kì phím j, phải tắt nóng thì khả năng cao liên quan đến cái driver Nvidia.
Bạn có thể thử: https://askubuntu.com/questions/757177/disable-nvidia-optimus-graphics-card

1 Like

Mặc định Ubuntu sẽ set swappiness về 60, nếu máy RAM thiếu (bao gồm cả RAM khủng long nhưng chạy nhiều tasks) sẽ dẫn tới việc tăng disk read/write do swappiness nằm trên đĩa.

Nếu để swappiness cao -> RAM không được tận dụng -> disk w/r tăng -> máy vừa chậm do nghẽn IO vừa làm giảm tuổi thọ disk

-> tốt nhất là set swappiness về 10, tức là chỉ dùng khi RAM ít hơn 10%

Hà Mã Tím đáng yêu đã làm rồi và đèn disk access hầu như tắt luôn do disk w/r giảm đáng kể, launch lại task cũ cũng nhanh hơn đăc biệt lúc build source

Cách thực hiện:
B1: Set swappiness tức thời

$sudo sysctl vm.swappiness=10

B2: Set swappiness mặc định:

$sudo nano /etc/sysctl.conf

thêm

vm.swappiness=10

vào cuối file

2 Likes
83% thành viên diễn đàn không hỏi bài tập, còn bạn thì sao?